Creating isometric groups
To be able to create an isometric drawing, first you have to create an isometric group that contains a pipeline or a set of piping objects. You can define the isometric group using:
-
One system: one pipeline or a set of piping objects.
-
Several systems: a set of piping objects or a block, system and pipeline.
Creating isometric groups for one pipeline
You can create an isometric group for one pipeline in the selected system. If the pipeline is too large for a single drawing, you can split the pipeline into multiple groups.
Prerequisites
-
All the relates objects are checked out to you, and they are not members of another isometric group.
Do the following:
-
On the Documents tab of Plant Modeller, click Piping Isometrics.
-
In the Piping Isometrics dialog, click the Select button or clear the option Several Systems to open the Select System dialog.
-
Select the required system from the list, and click OK.
-
Select Groups > Create pipeline isometrics. The Create Pipeline Isometrics for <System> dialog opens, listing the pipelines of the selected system.
-
Select the required pipeline from the list. A separate view opens, showing a preview of the selected pipeline.
-
You can click Browse to browse the pipeline in a view. Press Esc to return to the Piping Isometrics dialog.
-
You can click Adjust Splits to split the pipeline into several isometric groups, if a single group would not fit comfortably into a single drawing.
-
Click OK. The new isometric group or groups are listed in the Piping Isometrics dialog, and you can create drawings for them.
Creating isometric groups for piping objects in one system
You can create an isometric group for a set of piping objects that use the same system.
Prerequisites
-
All the relates objects are checked out to you, and they are not members of another isometric group.
Do the following:
-
On the Documents tab of Plant Modeller, click Piping Isometrics.
-
In the Piping Isometrics dialog, click the Select button or clear the option Several Systems to open the Select System dialog.
-
Select the required system from the list, and click OK.
-
Select Groups > Create isometric, enter a name for the isometric drawing, and click OK. A separate view opens, indicating that there are no objects in the isometric group yet.
-
Define the members of the group:
-
To add objects into the group, select the group and then Modify > Assign objects.
Select the objects you want to add, and press Enter to add them.
-
To remove objects from the group, select the group and then Modify > Deassign objects.
Select the objects you want to remove, and press Enter to remove them.
-
-
The new isometric group is listed in the Piping Isometrics dialog, and you can create a drawing for it.
Creating isometric groups for piping objects in multiple systems
You can create an isometric group for a set of piping objects that use different systems.
Prerequisites
-
All the relates objects are checked out to you, and they are not members of another isometric group.
Do the following:
-
On the Documents tab of Plant Modeller, click Piping Isometrics.
-
In the Piping Isometrics dialog, select the option Several Systems.
-
Select Groups > Create isometric, enter a name for the new drawing, and click OK. The new isometric group is listed in the Piping Isometrics dialog, and a separate view opens, indicating that there are no objects in the isometric group yet.
-
Define the members of the group:
-
To add objects into the group, select the group and then Modify > Assign objects.
Select the objects you want to add, and press Enter to add them.
-
To remove objects from the group, select the group and then Modify > Deassign objects.
Select the objects you want to remove, and press Enter to remove them.
-
-
The new isometric group is listed in the Piping Isometrics dialog, and you can create a drawing for it.
Creating isometric groups via containment, system and pipeline
You can create isometric groups for objects within a containment in the 3D model. This allows the containment hierarchy, such as blocks and named spaces, to define the contents of isometric drawings.
Prerequisites
-
Administrator has created the containment configuration in File > Environment > All library and project > [library] > Configuration > Plant Modeller > Containment Setup, and the required containment hierarchy is defined in the 3D model. Both logistics (e.g. blocks) and non-logistics containment (e.g. compartments) can be used to generate containment-based piping isometrics and spools.
-
In the settings of the Piping Isometrics tool, you have loaded an Isometric Drawing Name Generator that supports containment-based isometrics and spools. There is an example file "Exa8_MI_API.mac" which you can select from Tools > Options > Load.
-
To adjust automatic splitting during the process, automatic splitting has been enabled in the Configure Piping Isometrics options.
Do the following:
-
On the Documents tab of Plant Modeller, click Piping Isometrics.
-
In the Piping Isometrics dialog, make sure that the option Several Systems is selected.
-
Select Groups > Create isometrics via containment, system and pipeline.
-
In the Create Isometrics via Containment, System and Pipeline dialog, define the settings for creating isometrics, and click OK.
-
Selection Rules – Select the criteria for selecting objects.
-
Selection Limits – Only Objects Owned by This Site is always selected.
-
Objects are divided into isometrics by – Click Define to select the criteria for splitting objects into isometric groups.
-
Allow adjust isometric splitting – Select this option to be able to adjust the isometric groups before creating the isometric drawings, as described in Splitting isometric groups.
-
-
In the Generating piping isometrics dialog, select the containments that include the required piping objects, and click OK.
-
If the Systems dialog opens, select the systems whose objects to include in the selection, and click OK.
-
If the Pipelines dialog opens, select the pipelines whose objects to include in the selection, and click OK.
-
You are prompted for a drawing name. Enter a name and click OK. (This step repeats for each additional drawing.)
The Piping Isometrics dialog lists the new drawings.